View Full Version : Weird Computer Issue.

2007-07-27, 11:52 AM
Well I've got a computer I've been working on, and up until last night it worked fine. However, as of this morning, when I go to turn it on, one of two things happens:

If I turn it on with no keyboard or mouse plugged in, it will go to a "Keyboard error or no keyboard present" screen.

If I plug in a keyboard and turn it on, I get the same "Keyboard error or no keyboard present" message.

However, if I plug in a keyboard and a mouse, it won't turn on at all. I can hear the thing power on, but nothing ever shows up on the monitor.

Anyone care to speculate as to what's going on? My assumption is that the motherboard is failing, but I'd love to think there might be some more harmless answer... :annoyed:

2007-07-27, 11:59 AM
I've spent many years (around 14 or so) working on computer hardware issues and my best guess is that there is a short in the PS2 port on your motherboard. In most cases you WILL have to replace it. I work in a contract manufacturing facility that has a printed circuit board production area, and I do know how to use it. I personally would order a new PS2 circuit board connector and soldering on the new one in its place. If done improperly could cost you more than the motherboard though, but it can be done. I say just belly up a few bucks for a new one. I like www.newegg.com for reasonable prices and 3-day delivery. I only order my parts from them. Sorry I can't think of anything wlse it could be... :smallfrown:

2007-07-27, 12:09 PM
Well, it's a really old board anyway so I think I have one around here it can be replaced with... but the pain is going to be getting the board out and the new one in place. The whole computer is built in a tupperware bucket... :annoyed:

Obnoxiously large image:

2007-07-27, 12:25 PM
Are these USB or PS/2 devices?

More likely than not, you have a bad mouse or/and keyboard. Have you tried spares?

Other than that, a likely culprit is a bad solder joint on the motherboard. Cable connections are (obviously) subject to stresses, and sometimes break. This can usually be fixed by someone who knows what they are doing, but often it's easier and cheaper just to buy a new motherboard.

2007-07-27, 12:27 PM
They're both PS/2 devices, and I've tried working spares that give the same errors. The problem is definitely something bucket-side.

As I said, I was assuming it's a mobo failure issue... It just seems strange since it worked 100% fine last night when I shut it down, and hasn't been touched since.

2007-07-27, 12:33 PM
You know you just scored like 5,000 cool points for that tuperware computer! I'm an electronic engineer and just sent that pic to a few co-workers. I had one built in a pizza box once, and spray-painted it black :smallbiggrin:
Yah if it's an older mobo it might be easy to replace. I can see why you don't want to remove the old one though, since the plastic will wear out and get sloppy if you keep changing out hardware. :smallfrown:

2007-07-27, 12:33 PM
Sounds like a MB failure of sorts, though I'm curious WHY you're using a tupperware bucket...

2007-07-27, 12:55 PM
Why not? It was fun as hell to build, and I used all parts I got from old computers that relatives gave me... I actually spent more on the nuts and bolts to put the thing together than I did on the PC components. :biggrin:

The only real problem is ventilation... I REALLY need to put another fan or two in the thing.

2007-07-27, 01:12 PM
Yeah... (?)

Besides, don't those things build on static? (I might be wrong)

2007-07-27, 01:16 PM
Well this is interesting... I replaced the BIOS battery and unbent a pin under the PS/2 ports, and now instead of the keyboard not being noticed, the lights on the keyboard flash and it goes to the memory test screen... but when it gets through testing the memory, it just sits at a black screen that says "512 MB" in the top corner and "<F10=Setup>" in the bottom corner.

Needless to say, hitting F10 will not take me to setup.

I hate the way this motherboard boots... guess that's what I get for taking it from an old Compaq system. :annoyed:

Missing Shoe
2007-07-27, 03:00 PM
As for the PS/2 mouse thing: If it still gives you problems you can get a converter to USB for cheap, so if your PS/2 port is the only thing bad, you can still continue using USB.

As for the memory thing, a couple things to try (if you havent already) re-seat the memory (take it out, put it back in). Also try flashing the bios via the jumper or the battery. I know you just said you put a new one in but that has fixed many of problems for me over the years. IMO its always worth a shot.