View Full Version : Searching Errors

2006-01-04, 03:35 AM
When searching for posts from this page http://www.giantitp.com/cgi-bin/yabb/YaBB.pl?board=;action=search I get the following error after a long wait. When I search for posts by a particular user from their profile, I get the same error after a longer wait. It does not happen every time and I have not worked out what triggers it, will keep you posted.

Title: 500 Internal Server Error

Address: http://www.giantitp.com/cgi-bin/yabb/YaBB.pl?action=search2

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Web Server at giantitp.com

2006-01-04, 08:19 AM
Hmm, I think the same thing happened to me once when I searched in someone's profile for the posts they made...

2006-01-04, 09:33 AM
Searching for the term 'baldur gate'. Changing max age since last post (days), all other settings default.

7 - Worked
70 - Didn't work
50 - Didn't work
25 - Worked
30 - Worked
40 - Didn't work
50 (take 2) - Didn't work
35 - Didn't work
33 - Worked
34 - Worked
32 - Worked
31 - Worked
30 (take 2) - Worked
37 - Didn't work
36 - Worked
38 - Didn't work
36 (take 2) - Worked
38 (take 2) - Didn't work
35 (take 2) - Worked
37 (take 2) - Worked
38 (take 3) - Didn't work
39 - Didn't work
40 (take 2) - Didn't work
300 - Didn't work
3000 - Didn't work

Searching for last 10 posts (default) by user, this kind of search uses unlimited max age.
Sneak, 2141 posts - Didn't work
samiam303, 354 posts - Didn't work
Adrianna, 1 post - Didn't work

I think the problem could be to do with the max age of last post, it is strange that 35 wouldn't work then a few moments later 36 would work, I'm thinking it might not be a precise number that trips it, but that range that can cause problems depending on other variables (such as server load possibly). It is late however, and I won't rule out that I could have made a mistake with 35 and 37 not working the first time (but I doubt it).

2006-01-04, 01:05 PM
I feel special, you used me... ;D

2006-01-14, 08:22 AM
The server upgrade appears to have fixed this for me, maybe. I am not currently receiving this error on searches.