Under Settings->General Settings->Playground Skin, I selected the "Playground Sand" skin. In the past, what that setting did was make it so the forum always showed me the full version of the site, and never the mobile site (unless I was logged out). However, it no longer appears to be working.

On Chrome 88 on Android 11, I am shown the mobile site even when I am logged in. This isn't a big deal, because I have a workaround: I typically use Kiwi Browser and not Chrome. Kiwi has an option to send sites a desktop useragent string, which I typically keep enabled almost all the time. When Kiwi Browser sends the forum the UA string
Code:
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.152 Safari/537.36
I get the desktop site. But when Kiwi Browser (or Chrome) sends the UA string
Code:
Mozilla/5.0 (Linux; Android 11; Pixel 4a) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.152 Mobile Safari/537.36
then I get the mobile site. I understand that is the default behavior: you want to send users with a mobile user-agent string to the mobile site even though I personally think the mobile site is terrible. But if I have explicitly selected the desktop skin in my user settings, shouldn't I be getting the desktop site regardless of my browser's UA string?