I had a similar issue. Try running "xinput list" in the terminal and look for which device number says something like touchscreen. Then run "xinput disable [number]".

That will only persist until you restart your computer. On Mint there's a GUI for commands to run automatically on startup: I don't know what the Fedora equivalent would be.