My 10-evdev.conf looks like this:
Code:
Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "off"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "Ignore" "on"
EndSection
This should be correct. It even disables the driver in two different ways, I believe. But touch screen is definitely still on.