Support the GITP forums on Patreon
Help support GITP's forums (and ongoing server maintenance) via Patreon
Results 1 to 16 of 16
  1. - Top - End - #1
    Barbarian in the Playground
    Join Date
    May 2014
    Location
    Germany
    Gender
    Male

    Default Main site problem

    Quote Originally Posted by Rawhide View Post
    This thread is for forum issues only, please.

    That said, please check the link/bookmark you are using, or the URL you are typing in the address bar to make sure you are going to http://www.giantitp.com, and double check that it is http:// not https:// (only the forums are https at the moment) and includes the www. The site should still redirect you if any of those are missing, but sometimes your browser could experience errors.
    Sorry for posting in the wrong thread before.

    I did not use a bookmark, but the link from the Site Navigation here at the forum. But if nobody else got a problem, it's propably on my end. I will try again tomorrow.

  2. - Top - End - #2
    Pixie in the Playground
     
    BardGuy

    Join Date
    Feb 2020

    Default Re: Main site problem

    Having nearly the same problem. All links, images, comics, and redirects that are under the www . giantitp . com site will have the trailing slash of the main site clipped from the address.
    So, for example, www . giantitp . com/comics . html gets turned into www . giantitp . comcomics . html. Therefore, all images and links on the main page of www . giantitp . com are unloadable.
    Using the latest version of Firefox.
    The site works fine using MS Edge.
    This started happening around Monday, Feb 24, 2020.

    (Sorry, had to separate the addresses with spaces since the site won't let me post links, and it automatically turns anything that looks like a URL into a link.)
    Last edited by larper; 2020-02-27 at 02:43 PM.

  3. - Top - End - #3
    Barbarian in the Playground
    Join Date
    May 2019

    Default Re: Main site problem

    Quote Originally Posted by larper View Post
    Having nearly the same problem. All links, images, comics, and redirects that are under the www . giantitp . com site will have the trailing slash of the main site clipped from the address.
    So, for example, www . giantitp . com/comics . html gets turned into www . giantitp . comcomics . html. Therefore, all images and links on the main page of www . giantitp . com are unloadable.
    Using the latest version of Firefox.
    The site works fine using MS Edge.
    This started happening around Monday, Feb 24, 2020.

    (Sorry, had to separate the addresses with spaces since the site won't let me post links, and it automatically turns anything that looks like a URL into a link.)
    Same issue. Broken on Firefox, works on Edge. Latest comic is good as always.

  4. - Top - End - #4
    Pixie in the Playground
     
    BardGuy

    Join Date
    Feb 2020

    Default Re: Main site problem

    Quote Originally Posted by Tibbius View Post
    Same issue. Broken on Firefox, works on Edge. Latest comic is good as always.
    Ok, think I figured it out. This will affect all Firefox users that automatically update their Firefox browser.

    Mozilla is releasing DoH on by default. The giantitp website does not use https. For whatever reason, navigating to simple http addresses is not being resolved correctly by Firefox using the DoH servers. I fixed the problem by adding the giantitp domain to the network.trr.excluded-domains setting in about:config.

    Hopefully, when Mozilla rolls out DoH for real, they will have resolved this problem.
    Last edited by larper; 2020-02-27 at 04:46 PM.

  5. - Top - End - #5
    Ogre in the Playground
     
    PaladinGuy

    Join Date
    Mar 2012
    Location
    UK
    Gender
    Male

    Default Re: Main site problem

    Firefox version 73.0.1 (64-bit) here, and I am pretty sure it is set to auto-update - I cannot reproduce this problem so I don't think it is simply "Firefox", there must be more to it than that. Are you using a mobile version of firefox or the full browser? (I am using the full browser.)

  6. - Top - End - #6
    Pixie in the Playground
     
    BardGuy

    Join Date
    Feb 2020

    Default Re: Main site problem

    Quote Originally Posted by Khedrac View Post
    Firefox version 73.0.1 (64-bit) here, and I am pretty sure it is set to auto-update - I cannot reproduce this problem so I don't think it is simply "Firefox", there must be more to it than that. Are you using a mobile version of firefox or the full browser? (I am using the full browser.)
    Same version, full browser.

    All I can say is that once I found out that Mozilla was turning on DoH today, it sounded like it might be the problem. So I researched how to turn it off. Adding giantitp to the exclusion list seemed the best option and it cleared up the problem immediately.

    Could also have something to do with the combination of 73.0.1 and the OS. Windows 10 here.
    Last edited by larper; 2020-02-27 at 05:04 PM.

  7. - Top - End - #7
    Barbarian in the Playground
    Join Date
    May 2019

    Default Re: Main site problem

    Interesting. I didn't change anything about the config list and my excluded domains remain blank, but the problem with main page has gone away in Firefox now.

  8. - Top - End - #8
    Miniature Giant Space Hamster in the Playground Administrator
     
    Rawhide's Avatar

    Join Date
    Sep 2005
    Location
    Australia
    Gender
    Male

    Default Re: Main site problem

    The problem isn't with DoH (DNS over HTTPS). Our DNS servers support HTTPS. There's a bug in Firefox causing it to behave differently to every other browser on redirects. No big deal, the problem fixes itself after the first error, unless you also have another setting in Cloudflare enabled which causes it to trigger every single request. I just happened to fix it when you made the change.

    I can't wait to be rid of this old server entirely.

    "My Hobby: Replacing your soap with gravy" by rtg0922, Doll and Clint "Rawhide" Eastwood by Sneak

  9. - Top - End - #9
    Titan in the Playground
     
    Grey_Wolf_c's Avatar

    Join Date
    Aug 2007

    Default Re: Main site problem

    Quote Originally Posted by Rawhide View Post
    I can't wait to be rid of this old server entirely.
    If I may ask, is that the patreon-backed plan, or an idle wish?

    Grey Wolf
    Interested in MitD? Join us in MitD's thread.
    There is a world of imagination
    Deep in the corners of your mind
    Where reality is an intruder
    And myth and legend thrive
    Quote Originally Posted by woweedd View Post
    I would say that's the dumbest theory Grey Wolf's heard, but, let's be honest: It's Grey Wolf. They've probably heard dumber theories today. Point is, neat idea, but it's a real stretch.
    Ceterum autem censeo Hilgya malefica est

  10. - Top - End - #10
    Miniature Giant Space Hamster in the Playground Administrator
     
    Rawhide's Avatar

    Join Date
    Sep 2005
    Location
    Australia
    Gender
    Male

    Default Re: Main site problem

    Quote Originally Posted by Grey_Wolf_c View Post
    If I may ask, is that the patreon-backed plan, or an idle wish?

    Grey Wolf
    It's happening.

    "My Hobby: Replacing your soap with gravy" by rtg0922, Doll and Clint "Rawhide" Eastwood by Sneak

  11. - Top - End - #11
    Pixie in the Playground
     
    GnomeWizardGuy

    Join Date
    Oct 2019

    Default Re: Main site problem

    Quote Originally Posted by Rawhide View Post
    There's a bug in Firefox causing it to behave differently to every other browser on redirects. No big deal, the problem fixes itself after the first error

    Sorry, I'm no tech guru, but this is definitely not a Bug in Firefox.
    When trying to GET giantitp.com/comics/oots1193.html
    The server replies with
    Code:
    301 Moved Permanently
    [...]
    location: giantitp.comcomics/oots1193.html
    in the header, and Firefoy does the only right thing: redirecting to the URL given in the location header,
    and caching that answer, not trying to connect to /comics/oots1193.html again (because its 301'ed).

    And at least for me the Problem does not solve itself: sometimes the site does load, sometimes it doesn't.
    Deactivating the cache helped alot, but the site is still not working reliable.

  12. - Top - End - #12
    Miniature Giant Space Hamster in the Playground Administrator
     
    Rawhide's Avatar

    Join Date
    Sep 2005
    Location
    Australia
    Gender
    Male

    Default Re: Main site problem

    Quote Originally Posted by f00bar View Post
    Sorry, I'm no tech guru, but this is definitely not a Bug in Firefox.
    If you've got a problem that only occurs in one specific browser...

    I've made some changes to accomodate Firefox.

    P.S. If anyone is going to the old forums URL and doesn't get redirected to the new location, you're going to have some massive problems in a couple of weeks. Please ask your ISP why your DNS isn't updating.

    "My Hobby: Replacing your soap with gravy" by rtg0922, Doll and Clint "Rawhide" Eastwood by Sneak

  13. - Top - End - #13
    Pixie in the Playground
     
    BardGuy

    Join Date
    Feb 2020

    Default Re: Loading and/or speed issues

    Cannot navigate to comic, and the giantitp main site will not load images. When attempting to view the latest OOtS comic, get a message saying the site is not redirecting correctly.

    Firefox latest version.

  14. - Top - End - #14
    Ogre in the Playground
     
    ElfRogueGirl

    Join Date
    Jun 2018

    Default Re: Loading and/or speed issues

    Quote Originally Posted by larper View Post
    Cannot navigate to comic, and the giantitp main site will not load images. When attempting to view the latest OOtS comic, get a message saying the site is not redirecting correctly.

    Firefox latest version.
    To add to this, the problem seems to be related to either Firefox or a plug-in on Firefox, because I have the same problem but can see the comic properly on Chrome.

    Plug-ins are Ghostery, Adblock Plus and Avast.
    Last edited by Resileaf; 2020-03-05 at 12:40 PM.

  15. - Top - End - #15
    Pixie in the Playground
     
    BardGuy

    Join Date
    Feb 2020

    Default Re: Loading and/or speed issues

    Quote Originally Posted by Resileaf View Post
    To add to this, the problem seems to be related to either Firefox or a plug-in on Firefox, because I have the same problem but can see the comic properly on Chrome.

    Plug-ins are Ghostery, Adblock Plus and Avast.
    I use Adblock as well.

    The real issue is, none of these problems occurred until Feb 25th or so. It is either the latest version of Firefox where it turned on new security features by default, or it has something to do with changes to the site in support of the new forums.

  16. - Top - End - #16
    Miniature Giant Space Hamster in the Playground Administrator
     
    Rawhide's Avatar

    Join Date
    Sep 2005
    Location
    Australia
    Gender
    Male

    Default Re: Main site problem

    The main website is now on the new server and using https exclusively. Old links should redirect.

    Quote Originally Posted by Rawhide View Post
    P.S. If anyone is going to the old forums URL and doesn't get redirected to the new location, you're going to have some massive problems in a couple of weeks. Please ask your ISP why your DNS isn't updating.
    If you're having any issues, check the above link. If it doesn't redirect you, complain to your ISP. Your DNS should have stopped using that IP address months ago.

    "My Hobby: Replacing your soap with gravy" by rtg0922, Doll and Clint "Rawhide" Eastwood by Sneak

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •