Support the GITP forums on Patreon
Help support GITP's forums (and ongoing server maintenance) via Patreon
Results 1 to 3 of 3
  1. - Top - End - #1
    Ettin in the Playground
    Join Date
    Aug 2009

    Default Forum skin preference not working

    Under Settings->General Settings->Playground Skin, I selected the "Playground Sand" skin. In the past, what that setting did was make it so the forum always showed me the full version of the site, and never the mobile site (unless I was logged out). However, it no longer appears to be working.

    On Chrome 88 on Android 11, I am shown the mobile site even when I am logged in. This isn't a big deal, because I have a workaround: I typically use Kiwi Browser and not Chrome. Kiwi has an option to send sites a desktop useragent string, which I typically keep enabled almost all the time. When Kiwi Browser sends the forum the UA string
    Code:
    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.152 Safari/537.36
    I get the desktop site. But when Kiwi Browser (or Chrome) sends the UA string
    Code:
    Mozilla/5.0 (Linux; Android 11; Pixel 4a) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.152 Mobile Safari/537.36
    then I get the mobile site. I understand that is the default behavior: you want to send users with a mobile user-agent string to the mobile site even though I personally think the mobile site is terrible. But if I have explicitly selected the desktop skin in my user settings, shouldn't I be getting the desktop site regardless of my browser's UA string?

  2. - Top - End - #2
    Miniature Giant Space Hamster in the Playground Administrator
     
    Rawhide's Avatar

    Join Date
    Sep 2005
    Location
    Australia
    Gender
    Male

    Default Re: Forum skin preference not working

    There have been no changes to the settings of this forum.

    Note that you can override a default or chosen style with the URL (&styleid=X, where X is 2 Playground Sand or 3 for Playground Sand Mobile). Following a link or using a bookmark with this appended even once will make it your default until the session ends or you change the style manually.

    You can always change back to the desktop site quickly by tapping "Full Site" at the bottom of the page (it just sends you back to the same page with &styleid=2 appended).

    "My Hobby: Replacing your soap with gravy" by rtg0922, Doll and Clint "Rawhide" Eastwood by Sneak

  3. - Top - End - #3
    Ettin in the Playground
    Join Date
    Aug 2009

    Default Re: Forum skin preference not working

    It doesn't appear to be the result of following a link with a specific URL. If I open a new session of Chrome, go to the main giantitp.com page, and click on the sidebar link to the forum, the URL in my browser is
    Code:
    https://forums.giantitp.com/
    but I am still given the mobile skin. As I said, it isn't a big deal because I can work around it by using a desktop UA.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •